Box art - Infinity Blade II

Can My Device Play Infinity Blade II?

Wondering if your iPhone, iPad, or iPod Touch can run Epic Games' Infinity Blade II? We are too! We tracked down the developers and got the information straight from them.

It's important to note that Infinity Blade II requires iOS 4.0 or later to be installed on your device in order to run. Having an older iOS device means you can no longer update your device and therefore you are unable to run Infinity Blade II. Game Center integration also requires iOS 4.1 or later for iPhones and iPod Touch devices, while iOS 4.2 is required on iPads. iCloud integration requires iOS 5.0 or later to run as well.

Players with an iPhone 3GS, iPhone 4, iPhone 4S, or an iPhone 5 can play Infinity Blade II.
Players with an iPod Touch 3rd Generation (16GB or 32GB) or later can play Infinity Blade II.
Players with any kind of iPad can play Infinity Blade II.

Players with an iPhone 3G or earlier cannot play Infinity Blade II.
Players with an iPod Touch 3rd Generation 8GB cannot play Infinity Blade II.
Players with an iPod Touch 1st or 2nd Generation cannot play Infinity Blade II.
Players with an iPod Classic or Nano can't access the app store and therefore cannot play Infinity Blade II.