Harry Potter Wizards Unite Phone Requirements

At long last, the wizarding world of Harry Potter is in the hands of us Muggles (except we’re all wizards now, apparently) thanks to Harry Potter Wizards Unite, which is now available to download and play, depending on your region. What are, though, the Harry Potter Wizards Unite phone requirements? Read on through our guide to find out the Harry Potter Wizards Unite minimum specs and to see a Harry Potter Wizards Unite compatible devices list. We know, we’re magic for giving you all of this information. Go on, find out if your phone can run Harry Potter Wizards Unite.

Harry Potter Wizards Unite Phone Requirements | Minimum specs

Harry Potter Wizards Unite Phone Requirements

Despite what the developers Niantic might tell you, mobile phone games aren’t magic. They won’t magically appear on your phone even if you do think it should run it fine. There’s magic in the air with Harry Potter Wizards Unite, but not every one of you is allowed to see it. If your phone isn’t powerful enough, you just won’t be able to download the game. No amount of magic can fix this, unfortunately (unless you count buying a new more powerful phone as magic).

Below, we’ve got both the iOS minimum requirements and Android minimum requirements for you to take a look at (courtesy of Niantic). If your phone matches either list of system requirements, you should be able to download and play the game fine. Niantic’s disclaimer, however, should be remembered: “A small number of devices that meet the above criteria were individually marked as incompatible due to performance issues discovered in testing.”

Harry Potter Wizards Unite iOS Minimum Requirements

  • Beta OS versions and Jailbroken devices aren’t supported
  • GPS and Location Services enabled
  • Gyroscope and compass sensors enabled
  • iOS 10 or newer
  • iPhone 5s or newer
  • Strong internet connection (Wi-Fi, 3G, or 4G) required

Check through these specs. If your iPhone matches or exceeds the specifications listed above, you should be able to download and play Harry Potter Wizards Unite with no trouble.

Harry Potter Wizards Unite Android Minimum Requirements

  • 2 GB of free device storage required at least
  • 2 GB of RAM needed at least
  • Access to Google Play services
  • Android 5.0 or newer
  • Beta OS versions and Rooted devices aren’t supported
  • Camera required for some features
  • GPS and Location Services enabled
  • Gyroscope and compass sensors enabled
  • Preferred resolution of 720 x 1280 pixels (higher should be fine)
  • Strong internet connection (Wi-Fi, 3G, or 4G) required

As you can see, there are more requirements that you’ll need to match or surpass if you want to download and play Harry Potter Wizards Unite on your Android smartphone. Please have a read through the specs above, and see if your phone matches or surpasses them before you try to download the game. As Niantic stated, however, your phone may technically be able to run the game, but not smoothly at all, if this is the case it will unfortunately not be supported. Just because your phone can run Pokemon Go doesn’t mean that Harry Potter Wizards Unite will work, sadly.

Harry Potter Wizards Unite Phone Requirements | Compatible devices list

Harry Potter Wizards Unite Phone Requirements

If you’ve taken a look through the system requirements listed above for Harry Potter Wizards Unite and still find yourself confused by it all, we thought we’d help out even more by providing a list of compatible devices for the game. We don’t half treat you here at GameRevolution. Below, you’ll find a list of compatible iOS devices and Android devices for Harry Potter Wizards Unite.

Harry Potter Wizards Unite compatible iOS devices list

According to the official minimum specifications above, any iOS device that is older than an iPhone 5s or is under iOS 10 is not compatible with Wizards Unite. If you have any of these iPhones, however, you should be able to download and play Wizards Unite without any hassle (remember to update to iOS 10 or above if needs be):

  • iPhone 5s
  • iPhone 6
  • iPhone 6 Plus
  • iPhone 6s
  • iPhone 6s Plus
  • iPhone SE
  • iPhone 7
  • iPhone 7 Plus
  • iPhone 8
  • iPhone 8 Plus
  • iPhone X
  • iPhone XR
  • iPhone XS
  • iPhone XS Max

Harry Potter Wizards Unite compatible Android devices list

Before you have a look through the compatible Android devices list below, we thought we’d warn you that these have been confirmed by Zeroghan, WizardsUniteHub official administrative account. Please take the following list of known compatible and incompatible Android devices with a pinch of salt as the list hasn’t been officially confirmed by Niantic.

Android Phones compatible with Harry Potter Wizards Unite:

  • Huawei Honor 8
  • Huawei P10
  • Huawei P20 Lite
  • LG G6+
  • OnePlus 3T+
  • Pixel 1XL, Pixel 3XL
  • Pocophone F1
  • Samsung A3 (2017)
  • Samsung Galaxy S6, S7, S8, S9, S10
  • Samsung Note 9
  • Sony Xperia Z3
  • Zenfone 3

Of course, there will be more Android smartphones that are compatible with Wizards Unite than these. Simply check the specifications above to see if your phone should download and play the game.

Android Phones incompatible with Harry Potter Wizards Unite:

  • Alcatel A30 tablet
  • Huawei Mate 10 Lite
  • Huawei Nova 2i
  • Huawei P9 lite
  • Huawei Y6 2018
  • LG Aristo 2
  • LG Fortune 2
  • LG K10
  • LG K30
  • LG K30 Plus
  • LG Phoenix 4
  • LG Stylo 3
  • LG Stylo 4
  • Moto G 4 Play (Android 7.1.1)
  • Moto G Turbo Edition
  • Motorola G7 Play
  • Nexus 5X
  • Nokia 5 TA-1024 (we can confirm that this phone isn’t compatible ourselves)
  • Samsung A3
  • Samsung Galaxy Gran Duos Prime TV ( Android 5.1.1)
  • Samsung Galaxy J5
  • Samsung Galaxy J6
  • Samsung Galaxy J7 (2016), android 8.1.0
  • Samsung Galaxy ON5
  • Samsung galaxy orbit J3 2018 android 8
  • Samsung S4 Mini
  • Sony Xperia E5
  • Sony Xperia XA1
  • Sony Xperia XA2
  • Xiaomi 5A
  • Xiaomi Redmi 6
  • ZTE Max Blade 4
  • ZTE Max Blade X

Again, there will be hundreds of more Android devices than these that won’t be compatible with Wizards Unite. If your phone is below Android 5.0, it won’t run Wizards Unite, for example. Please do read through the minimum specs above to see if your phone should be able to run Wizards Unite.